PAT Advanced 1041 Be Unique (20) [Hash散列]

题目

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N(<=10^5) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

题目分析

  1. 定义数组ns[N],存放输入数字
  2. 定义数组ts[10001],记录输入数字出现次数
    • 大小为10001,(题目已知:输入数字取值范围[1, 10^4])
    • 数组下标--输入数字
    • 数组元素--输入数字出现次数
  3. 遍历输入数字(ns数组),最早出现次数==1(表明是唯一数),打印退出

易错点

  1. 若没有唯一数时,打印None,注意None后不需要加"\n"就可以AC

Code

Code 01

#include <iostream>
//#include <>
using namespace std;
int main(int argc, char * argv[]){
    int N,m;
    scanf("%d",&N);
    int ns[N];
    int ts[10001]={0};
    for(int i=0;i<N;i++){
        scanf("%d",&ns[i]);
        ts[ns[i]]++;
    } 
    bool flag = false;
    for(int i=0;i<N;i++){
        if(ts[ns[i]]==1){
            printf("%d",ns[i]);
            flag = true;
            break;
        }
    }
    if(!flag)printf("None");
    return 0;
}


猜你喜欢

转载自www.cnblogs.com/houzm/p/12238454.html