PAT 1041 Be Unique (20)

1041 Be Unique (20)(20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

思路:

本题是要找出第一个不重复的数字,用数组来存数字,用map来统计出现的次数。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

map<int, int> m;
int n, a[100005];

int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> a[i];
		m[a[i]]++;
	}
	for (int i = 0; i < n; i++)
	{
		if (m[a[i]] == 1)
		{
			cout << a[i] << endl;
			return 0;
		}
	}
	cout << "None" << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81539372