PAT A1041 Be Unique散列

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

 代码:

#include <iostream>

using namespace std;

const int maxn=10010;
int main()
{
    int n;
    cin >> n;
    int bets[n];  //bets存储猜的数
    int hashtable[maxn]={0};  //hashtable[i]==0说明i数没有被猜
    for(int i=0;i<n;i++){
        scanf("%d",&bets[i]);
        if(hashtable[bets[i]]==0)
            hashtable[bets[i]]=1;
        else
            hashtable[bets[i]]=-1;  //-1表示被猜过了
    }
    int i=0;
    for(;i<n;i++){
        if(hashtable[bets[i]]==1){
            printf("%d",bets[i]);
            break;
        }
    }
    if(i==n)
        printf("None");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/86769567