hdu 1525 Euclid's Game(博弈 找规律)

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

题解:
题目:不停的用较大的数减去两者中较小的数的倍数,直到一方是另一方的倍数为止,谁先得到x, nx的形式谁就赢

假设输入得两个数为n 和 m, 假定 n>m
- 1.若n % m == 0 由题意知,先手一定赢
- 2.若n % m != 0时
- 2.1 当n > 2m, 由于先手很聪明,所以他知道(n % m, m)的局面是否为必胜态。如果为必胜态,先手就将(n, m)的局面变成(n % m + b, b), 让后手不得不为先手创造出(n %m, m)的必胜态, 先手赢;如果为必败态,先手就将(n, m)的局面变成(n % m, m), 这样必败态的下一个局面还是必胜态, 先手赢。
结论:n > 2m 时, 先手必胜
- 2.2 当m < n < 2m 他的下一步一定是(n - m, m),先手没有选择的余地, 所以遇到这种情况 只能听天由命,不停相减 直到遇到n% m == 0的情况停止,这就不一定先手能赢喽~让程序说话~

os:我没注意到是可以减倍数这一点,,,所以迟迟找不到规律,,,太菜了

 #include<bits/stdc++.h>
 using namespace std;

int main(){
    int n, m;
    while(scanf("%d%d", &n, &m), n||m){
        bool flag = 1;
        if(n < m)
            swap(n, m);
        while(m){
            if(n % m == 0 || n > 2*m){
                break;
            }
            else{
                n = n-m;
                swap(n, m);
                flag ^= 1;//异或同假异真 判断先手是否能位于必胜点
            }
        }
        if(flag)
             printf("Stan wins\n");
        else if(flag == 0)
            printf("Ollie wins\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81297504