【HDU - 1564 】Play a game (博弈问题,找规律,奇偶博弈)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/82831705

题干:

New Year is Coming! 
ailyanlu is very happy today! and he is playing a chessboard game with 8600. 
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line. 
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner ("8600" or "ailyanlu") for each input line except the last zero. 
No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

8600

解题报告:

找规律得偶数则先手胜,奇数则后手胜

贴两篇证明:

http://www.cnblogs.com/kuangbin/archive/2013/07/22/3204654.html

https://blog.csdn.net/topc0o0der/article/details/5928391

AC代码:

#include<bits/stdc++.h>

using namespace std;

int main()
{
	int n;
	while(~scanf("%d",&n) && n) {
		if((n&1) == 1) puts("ailyanlu");
		else puts("8600");
	}
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/82831705