hdu 1564 Play a game(博弈 找规律)

New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input
The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output
Output the winner (“8600” or “ailyanlu”) for each input line except the last zero.
No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

8600

emmm,画了一下图, 画到n=4时就发现 奇数时是ailyanlu赢, 偶数时是8600赢
os:竟然有人叫8600 我服了

#include<bits/stdc++.h>
using namespace std;

int main(){
    int n;
    while(scanf("%d", &n), n){
        if(n % 2 == 0)
            printf("8600\n");
        else
            printf("ailyanlu\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81296577