HDU 1171【01背包水题】

先上题

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/

32768 K (Java/Others)
Total Submission(s): 43557    Accepted Submission(s): 14972


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
 
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 
Sample Output
 
  
20 10 40 40
#include<iostream>
using namespace std;
#include<algorithm>
#include<string.h>

int value[5010];
int dp[260000];
int main()
{
	int n;
	while (scanf("%d", &n) != EOF, n >0)
	{
		memset(value, 0, sizeof(value));
		memset(dp, 0, sizeof(dp));
		int sum = 0;
		int j = 0;
		for (int i = 0; i < n; i++)
		{
			int a, b;
			scanf("%d%d", &a, &b);
			while (b--)
			{
				value[j++] = a;
				sum += a;
			}
		}
		for (int i = 0; i < j; i++)
		{
			for (int j = sum / 2; j >= value[i]; j--)
			{
				dp[j] = max(dp[j], dp[j - value[i]] + value[i]);
			}
		}
		cout << sum - dp[sum / 2] << " " << dp[sum / 2] << endl;
	}
	return 0;
}


注意所开的value和dp数组的大小,不要过小,要用memset,={0}不知道为什么会WA,输入n时,要写n>0,不要写,
n!=-1,会TLE,被坑了n多次
发布了19 篇原创文章 · 获赞 15 · 访问量 1790

猜你喜欢

转载自blog.csdn.net/ned158/article/details/77199378