HDU-1171 Big Event in HDU 变形01背包

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40

题目大意:把一堆东西分成两份,使得两份东西总价值最接近。
思路:总价值求和,分成两半,直接01背包即可。

AC代码

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int val[5005];
int dp[255555];

int main() {
    int n,l, sum;
    while (cin>>n && n) {
        memset(val, 0, sizeof(val));
        memset(dp, 0, sizeof(dp));
        l = 0;
        sum = 0;
        for (int i = 0; i < n; i++) {
            int a,b;
            cin>>a>>b;
            while (b--) {
                val[l++] = a;
                sum += a;
            }
        }
        for (int i = 0; i < l; i++) {
            for (int j = sum / 2; j >= val[i]; j--) {
                dp[j] = max(dp[j], dp[j - val[i]] + val[i]);
            }
        }
        cout<<sum - dp[sum / 2]<<" "<<dp[sum / 2]);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42764823/article/details/88615244
今日推荐