HDU1171 Big Event in HDU 多重背包

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tawn0000/article/details/82526144
 

                                    Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51283    Accepted Submission(s): 17523


 

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

 

Sample Input

 

2 10 1 20 1 3 10 1 20 2 30 1 -1

 

Sample Output

 

20 10 40 40

 

Author

lcy

直接以sum/2为背包容量进行多重背包dp即可。

#include <bits/stdc++.h>

using namespace std;
typedef pair<int,int> P;
typedef long long LL;
const int maxn = 250000 + 100;
const int INF = 0x3f3f3f3f;
const int mod = 530600414;
int T,n;

int dp[maxn];
int v[maxn],m[maxn];

int main()
{
  while(scanf("%d",&n) && n >= 0)
  {
  int sum = 0;
  memset(dp,0,sizeof(dp));
  for(int i = 0; i < n; i++) {scanf("%d%d",&v[i],&m[i]); sum += v[i] * m[i];}
  for(int i = 0; i < n; i++)
    for(int k = 1; k <= m[i]; k++)
      for(int j = sum/2; j-k*v[i] >= 0; j--)
         dp[j] = max(dp[j],dp[j-k*v[i]] + k*v[i]);
  printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/Tawn0000/article/details/82526144