HDU1171——01背包入门基础题

题目:

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B. 

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

大意是:有N种不同设施,每一行输入一种设施的价值和数量,把所有设施分成两组,使得这两组设施的价值尽量接近。最后输出这两组设施各自的价值,要求前面的数大于后面的数。

其实本质上也是属于01背包,可以理解成容量没有限制,但价值有限制的背包。

计算出所有设施的价值sum,除以2得到sum_half,构造背包,其最大价值,也就是最大“容量”为sum_half,使其获得最大价值。

这个背包没有容量,所以不用开数组w[ ]。另外将多个的同一种的设施的价值一个一个来进行存储,可以通过vector来存比较方便些,这里是用普通数组存储。

初始状态为0,状态转移方程为:dp[ j ] = max {     dp[ j ]    ,    dp[ j - v[ i ] ]  +  v[ i ]     }   ;

同时注意物品总数就不是给出的N了,而应该是数组v[ ]的大小。

这个背包的最大价值是最接近总价值的一半 并且 小于等于总价值的一半。所以分别取 dp[ sum_half ] 和 sum - dp[ sum_half ] 两者的最大最小值输出就可以了。

代码:

//
//  main.cpp
//  HDU1171
//
//  Created by jinyu on 2018/7/17.
//  Copyright © 2018年 jinyu. All rights reserved.
//

#include <iostream>
#include <algorithm>
using namespace std;

int w;
int v[100000+77];
int dp[100000+77];

int main(){
    int N;
    cin>>N;
    while(N>=0){
        memset(dp, 0, sizeof(dp));
        int nn = N;
        int sum = 0;
        int index = 0;
        while(nn--){
            int vv;
            cin>>vv>>w;
            int num = w;
            while(num--){
                v[index++] = vv;
            }
            sum += vv * w;
        }
        int sum_half = sum/2;
        //cout<<sum_half<<endl;
        for(int i = 0;i<index;i++){
            for(int j = sum_half;j>=v[i];j--){
                dp[j] = max( dp[j] , dp[j-v[i]] + v[i]);
               // cout<<dp[j]<<endl;
            }
        }
        cout<<max( dp[sum_half] , sum-dp[sum_half])<<" "<<min( dp[sum_half] , sum-dp[sum_half])<<endl;
        cin>>N;
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41508508/article/details/81083724