POJ2955 Brackets(区间DP)

Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6635   Accepted: 3569

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
 
 
 
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,j,k,x,len,dp[102][102];
	char a[102];
	while(gets(a)!=NULL)
	{
		if(a[0]=='e') break;
		memset(dp,0,sizeof(dp));
		len=strlen(a);
		for(k=1;k<len;k++)//表示区间长度 
		for(i=0,j=k;j<len;i++,j++)
		{
			if(a[i]=='('&&a[j]==')'||a[i]=='['&&a[j]==']')
			dp[i][j]=dp[i+1][j-1]+2;//对应两个 
			for(x=i;x<j;x++)// 区间最值合并 
			dp[i][j]=max(dp[i][j],dp[i][x]+dp[x+1][j]);
		}
		printf("%d\n",dp[0][len-1]);
	}
	return 0;
}

发布了34 篇原创文章 · 获赞 109 · 访问量 12万+

猜你喜欢

转载自blog.csdn.net/huihui1094667985/article/details/52810392