POJ - 2955 Brackets (区间DP)

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

思路:从后往回找,如果找到一个‘)’或‘]’与当前的'('或'['对应,则加2。dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2)。

#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
char a[110],mp[200];
int dp[110][110];
int main()
{
    mp['(']=')';
    mp['[']=']';
    while(~scanf("%s",a),strcmp(a,"end"))
    {
        int len=strlen(a);
        memset(dp,0,sizeof(dp));
        for(int i=len-1;i>=0;i--)
        {
            for(int j=i+1;j<len;j++)
            {
                dp[i][j]=dp[i+1][j];
                for(int k=i;k<=j;k++)
                {
                    if(mp[a[i]]==a[k])
                    {
                        dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
                    }
                }
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/83590912