POJ 2955 Brackets(括号匹配-区间DP)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/June_Xixi/article/details/76099297

题目链接:http://poj.org/problem?id=2955

Brackets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8302   Accepted: 4417

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 …an, your goal is to find the length of the longest regular brackets sequence that is a subsequence ofs. That is, you wish to find the largestm such that for indicesi1,i2, …,im where 1 ≤i1 <i2 < … <imn, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is[([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters(,), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004

题意:求最大括号匹配数,( )、[ ].

若i、j不匹配,则dp[i][j] = dp[i + 1][j];若i、j匹配,则dp[i][j] = max{dp[i][k] + dp[k + 1][j]} + 2.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[110];
int dp[110][110];

int main()
{
	while(~scanf("%s", s + 1) && s[1] != 'e') {
		int l = strlen(s + 1);
		memset(dp, 0, sizeof(dp));
		
		for(int i = l - 1; i >= 1; i --)
            for(int j = i + 1; j <= l; j ++)
            {
                dp[i][j] = dp[i + 1][j];
                for(int k = i + 1; k <= j; k ++)
                {
                    if(s[i] == '(' && s[k] == ')' || s[i] == '[' && s[k] == ']')
                        dp[i][j] = max( dp[i][j], dp[i + 1][k - 1] + dp[k + 1][j] + 2);
                }
            }
        printf("%d\n", dp[1][l]);
			
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/June_Xixi/article/details/76099297