POJ2955 Brackets(区间DP)

POJ2955 Brackets(区间DP)

Description
We give the following inductive definition of a “regular brackets” sequence:the empty sequence is a regular brackets sequence,if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence.For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

题意

匹配字符串里的“()”和“[]”,每匹配到一个加2,匹配过的符号不可以重复匹配。状态转移方程为dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j])。此题目通过区间为2的小区间向大区间递推,所以在枚举区间时,先要if((str[i]’(’&&str[j]’)’)||(str[i]’[’&&str[j]’]’)) dp[i][j]=dp[i+1][j-1]+2;判断区间的边界是否能匹配到并且加2。

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<functional> 
#include<map>
using namespace std;
typedef long long ll;
const int N=1e6+10,NN=2e3+10,INF=0x3f3f3f3f;
const ll MOD=1e9+7;
int len;
int dp[NN][NN];
char str[NN];
void init(){
	memset(dp,0,sizeof dp);
}
int main(){
	while(scanf("%s",str+1)&&strcmp(str+1,"end")!=0){
		init();
		len=strlen(str+1);
		for(int l=1;l<=len;l++){
			for(int i=1;i<=len-l+1;i++){
				int j=i+l-1;
				if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']')) dp[i][j]=dp[i+1][j-1]+2;//由区间为2的dp往上递推 
				for(int k=i;k<j;k++) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
			}
		}
		printf("%d\n",dp[1][len]);
	}
}

猜你喜欢

转载自blog.csdn.net/Hc_Soap/article/details/107522242