POJ2955 Brackets #区间DP#

Brackets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17043   Accepted: 8831

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
4
0
6

Source

Solution

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long ll;
const int maxn = 110;
int dp[maxn][maxn];
string s;

bool match(int i, int j)
{
    if (s[i] == '[' && s[j] == ']') return true;
    if (s[i] == '(' && s[j] == ')') return true;
    return false;
}

int main()
{
    while (cin >> s && s != "end")
    {
        memset(dp, 0, sizeof(dp));
        int len = (int)s.length();
        for (int l = 1; l < len; l++)
        {
            for (int i = 0, j = i + l; j < len; i++, j++)
            {
                if (match(i, j)) dp[i][j] = dp[i + 1][j - 1] + 2;
                for (int k = i; k < j; k++) dp[i][j] = max(dp[i][j], dp[i][k] + dp[k + 1][j]);
            }
        }
        printf("%d\n", dp[0][len - 1]);
    }
    return 0;
}
发布了367 篇原创文章 · 获赞 148 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/104102667