Brackets POJ - 2955(区间dp)

Brackets POJ - 2955

We give the following inductive definition of a “regular brackets” sequence:

    the empty sequence is a regular brackets sequence,
    if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
    if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

    (), [], (()), ()[], ()[()]

while the following character sequences are not:

    (, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意:

求最长括号匹配的子序列

分析:

dp[i][j]表示区间[i,j]的最长匹配子序列的长度

这样对于一个新的区间[i,j]

如果s[i],s[j]两个位置的括号是匹配的那么长度一定可以加2

即: d p [ i ] [ j ] = d p [ i + 1 ] [ j 1 ] + 2

然后枚举区间[i,j]的中间值,比较如果分开能否变得更长

即: d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k + 1 ] [ j ] )

因为题目说了,两个匹配的序列合在一起也是匹配的

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 105;
char s[N];
int dp[N][N];
inline bool check(int i,int j){
    if(s[i] == '[' && s[j] == ']')
        return true;
    if(s[i] == '(' && s[j] == ')')
        return true;
    return false;
}
int main(){
    while(~scanf("%s",s+1)){
        if(s[1] == 'e') break;
        memset(dp,0,sizeof(dp));
        int n = strlen(s+1);
        for(int i = n; i >= 1; i--){
            for(int j = i+1; j <= n; j++){
                if(check(i,j)) dp[i][j] = dp[i+1][j-1] + 2;
                for(int k = i; k < j; k++){
                    dp[i][j] = max(dp[i][j],dp[i][k]+dp[k+1][j]);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81388349