POJ 2955 Brackets 区间dp

http://poj.org/problem?id=2955

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

枚举区间长度,然后如果最右端的额括号能和中间某个括号匹配就加1,转移方程就为:
dp[i][j]=max(dp[i][j],dp[i][k-1]+dp[k+1][j]+1),第k个括号和第j个括号匹配
代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

typedef long long LL;
const int maxn=105;
int dp[maxn][maxn];
inline bool match(char a,char b)
{
    if(a=='('&&b==')') return true;
    if(a=='['&&b==']') return true;
    return false;
}
int main()
{
    char str[maxn];
    while(scanf("%s",str+1)){
        if(strcmp(str+1,"end")==0)
            break;
        memset(dp,0,sizeof dp);
        int length=strlen(str+1);
        for(int len=1;len<=length;len++){
            int l,r;
            for(l=1;l+len-1<=length;l++){
                r=l+len-1;
                dp[l][r]=dp[l][r-1];
                for(int k=l;k<r;k++){
                    if(match(str[k],str[r]))
                        dp[l][r]=max(dp[l][r],dp[l][k-1]+dp[k+1][r-1]+1);
                }
            }
        }
        printf("%d\n",dp[1][length]*2);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/blue_kid/article/details/79180024