[区间DP] 括号匹配 POJ2955

Brackets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12798   Accepted: 6792

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, imwhere 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

<span style="color:#000000">((()))
()()()
([]])
)[)(
([][][)
end</span>

Sample Output

<span style="color:#000000">6
6
4
0
6</span>

Source

Stanford Local 2004

#include <iostream>
#include <cstdio>
#include <string> 
#include <cstring>
#define ll long long
using namespace std;
const ll mod = 1e9 + 7;
const int mn = 3e5 + 10;

char ch[200];
int dp[110][110];
int main()
{
	while (~scanf("%s", ch))
	{
		memset(dp, 0, sizeof dp);
		if (ch[0] == 'e')
			break;
		
		int len = strlen(ch);
		for (int i = 0; i < len; i++)
			dp[i][i] = 0;
		
		for (int l = 2; l <= len; l++)
		{
			for (int i = 0; i < len; i++)
			{
				int j = i + l - 1;
				if (j >= len)
					break;
				
				if ((ch[i] == '(' && ch[j] == ')') || (ch[i] == '[' && ch[j] == ']'))
					dp[i][j] = dp[i + 1][j - 1] + 2;
				for (int k = i + 1 ; k <= j - 1; k++)
					dp[i][j] = max(dp[i][j], dp[i][k] + dp[k][j]);
			}
		}
		cout << dp[0][len - 1] << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/84400541
今日推荐