poj2955(区间dp)

Brackets

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13828   Accepted: 7286

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

Stanford Local 2004

时间真可怕。区间dp入门题都忘了。

逆向思维感觉初始化方便,dp【i】【j】表示区间i-j最小的不合法个数。从小区间到大区间枚举。这里进行初始化时,由于我想让dp【3】【2】没错,就是区间3-2.因为区间dp【2】【3】的下一个就是这个为0,而其他的又想是INF,所以初始化INF放在里面,用时再INF。

代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<cstring>
using namespace std;
int dp[110][110];
const int INF=0x3f3f3f3f;
int main()
{
    string h;
    while(cin>>h){
        if(h=="end")
            break;
        int ll=h.size();
        memset(dp,0,sizeof(dp));
        for(int i=0;i<ll;i++){
            dp[i][i]=1;
        }
        for(int len=1;len<ll;len++){
            for(int i=0;i<ll;i++){
                int j=i+len;
                if(j>=ll)
                    break;
                dp[i][j]=INF;
                if((h[i]=='('&&h[j]==')')||(h[i]=='['&&h[j]==']')){
                    dp[i][j]=dp[i+1][j-1];
                }
                for(int k=i;k<=j;k++){
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);
                }
            }
        }
        cout<<ll-dp[0][ll-1]<<endl;
    }
    return 0;
}
发布了565 篇原创文章 · 获赞 110 · 访问量 11万+

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/88599693