寒假私训——二分 E - Pie

Pie

题目描述

 My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input
One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

题目大意

n块馅饼,f+1个人分,要求不能将不同的馅饼拼凑在一起,给出n块馅饼的半径,求每个人所能分到的最大面积。

解题思路

先将第i块馅饼的面积放进a[i]中,然后找目标值的范围【0,max(a[i])】,然后将mid送到chack函数中,chack函数检查每一块馅饼面积a[i]除以mid,看能分成几块,如果分的块数大于f+1,说明mid比目标值小,选择右部。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#define pi acos(-1.0)
#define minn 1e-5
using namespace std;
int t,n,f;
double a[10010];
bool chack(double x)
{
    int sum=0;
    for(int i=0;i<n;++i)
    {
        sum+=(int)(a[i]/x);  //看看馅饼按照x大小来分,应该要分成多少.这里一定要套括号!!!
        }
    if(sum>=f) return 1;
    return 0;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&f);
        f++;
        for(int i=0;i<n;++i)
        {
            scanf("%lf",&a[i]);
            a[i]=pi*a[i]*a[i];
        }
        sort(a,a+n);
        double L=0,R=a[n-1],mid;
        mid=(L+R)/2;
        while(R-L>minn)
        {
            if(chack(mid))L=mid;
            else R=mid;
            mid=(L+R)/2;
        }
        printf("%.4f\n",mid);
    }
    return 0;
}
发布了36 篇原创文章 · 获赞 1 · 访问量 1392

猜你喜欢

转载自blog.csdn.net/atnanajiang/article/details/104063159
今日推荐