HDU 1969 Pie (简单的二分)

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16239    Accepted Submission(s): 5734


 

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

 

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

 

Sample Input

 

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

 

Sample Output

 

25.1327 3.1416 50.2655

题意就是给你n块披萨有m+1个人(已加上他自己), 给出每个披萨的半径,要求分配这些披萨,每个人分得的大小都是相同的,且每个人的披萨必须是一块,不能是几块小的

思路:题目问的是能够分成m+1块的每块的最大面积x,就是求这个x。

由于每块整披萨面积s可以分成的每块面积为x小块的数量为s/x,所以我们只要看所有的披萨能分成的数量与m+1相比即可

AC代码

#include<iostream>
#include<cstdio>
#include<cstring> 
#include<cmath>
#include<algorithm>
#define eps 1e-6   //
#define PI acos(-1.0) //圆周率 
using namespace std;

double r[10005];
int n,m;
int solve(double x)
{
	int sum=0;
	for(int i=1;i<=n;i++)
	{
	   	sum+=(r[i]*r[i]*PI)/x;//sum表示从1到n这些蛋糕能切得面积为x的总数量 
	}
	if(sum>=m+1) return 1;//千万不要忘了加上自己 
	else return 0;
}
int main()
{
	int t;
	//double ans,mid;
	double lb,ub;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		{
			scanf("%lf",&r[i]);
		}
		sort(r+1,r+n+1);
		lb=0;
		ub=(r[n]*r[n])*PI;
		while(ub-lb>eps) //如果不设置精度eps,while死循环 
		{
			double mid=(ub+lb)/2;
			if(solve(mid))
			{
				lb=mid;
			}
			else ub=mid;
			
		}
		printf("%.4lf\n",lb);
		}	
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/zvenWang/article/details/81430387