pie(二分)

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:<ul><li>One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.<li>One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.</ul>

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10<sup>3</sup>.

Sample Input

 

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

Sample Output

 

25.1327 3.1416 50.2655

题意:把一个派等份的分给f+1个人,注意把自己算在内,要求能分的最大尺寸,

思路:二分,对尺寸二分,下界0,上届最大值,注意精度问题,特别是pi,处理时先不算pi,只求平方,最后结果再乘pi,保证精度

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iomanip>
#define pi 3.1415926535897932
double a[10005];
double v[10005];
using namespace std;
int main()
{
    int t;
    double n,f,r,mx=-1000000,sum;
    cin>>t;
    while(t--)
    {
        cin>>n>>f;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        v[i]=a[i]*a[i];


            mx=max(mx,v[i]);
        }
       double  r=mx;
       double mid;
       double l=0.0 ;

        while(r-l>1e-6)
        {int k=0;
             mid=(l+r)/2;
          for(int i=1;i<=n;i++)
          k+=(int)(v[i])/mid;
          if(k<f+1)
            r=mid;
            else
            l=mid;

        }
        cout<<fixed<<setprecision(4)<<pi*mid<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81741777