Pie(二分)

Pie

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 
Pie

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

题目:把n个pie分给m个人,求每个人最多能分到多少,(每个人一样多,一个人的pie不能是多个pie拼凑来的),给出n个pie的半径。

思路:二分最大面积,如果面积为mid的pie能分出m个。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define IP 3.14159265358979
long long a[10005];
int n,m;
bool cmp(int a,int b)
{
    return a>b;
}
bool hhh(long long k)
{
    long long ans=0;
    for(int j=0; j<n; j++)
    {
        ans+=a[j]/k;
    }
    if(ans>=m)
        return 1;
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int x;
        scanf("%d%d",&n,&m);
        m++;
        long long r=0,l=0,ans,mid;
        for(int i=0; i<n; i++)
            scanf("%d",&x),a[i]=IP*x*x*1000000,r+=a[i];
        sort(a,a+n,cmp);
        while(l<=r)
        {
            mid=(l+r)/2;
            if(hhh(mid))
            {
                l=mid+1;
                ans=mid;
            }
            else
                r=mid-1;
        }
        printf("%.4lf\n",ans/1000000.0);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81745562