HDU1969:Pie(二分) ʕ •ᴥ•ʔ

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1449    Accepted Submission(s): 499


 

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

扫描二维码关注公众号,回复: 2826695 查看本文章

Sample Input

 

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

Sample Output

 

25.1327 3.1416 50.2655

Source

NWERC2006

Recommend

wangye


题意:给出n个蛋糕的半径,还有m+1个人,每个人的馅饼必须是整块的,不能拼接,求最大的。

思路:因为不能拼接,所以直接在最大那块的面积与0之间二分求即可

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
#include <map>
#define pi acos(-1.0)
using namespace std;
int n,m;
double a[10010];
int find(double w)
{
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		ans+=int(a[i]/w);//这里需要加int不然不过 。。玄学
	}
	if(ans>=m+1)
		return 1;
	return 0;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n>>m;
		double r=0;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
			a[i]=a[i]*a[i]*pi;
			r=max(r,a[i]);
		}
		double l=0;
		double ans;
		while(r-l>1e-6)
		{
			double mid=(l+r)/2;
			if(find(mid))
			{
				ans=mid;
				l=mid+0.000001;
			}
			else
			{
				r=mid-0.000001;
			}
		}
		printf("%.4lf\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81745558