寒假私训——二分 A - Cable master

电缆问题

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces. 

Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).
Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

答题思路

该问题和前一篇文章的例二相似,需要找到边界——最小大于0,最大是理想情况下(每一根电缆长度相同),电缆长度和除以要求段数。要求找出符合条件的最大值,所以保留左部。但是这题里有一个大坑——精度。double型数字容易丢精度,所以要“R=(int)(R*100)/100.0”

代码区

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>


using namespace std;
const int maxn=10005;
const double minn=1e-8;
double a[maxn],R,L,mid;

int main()
{
    long long num1,de;
    double sum;
    cin>>num1>>de;
    sum=0;
    for(int i=1;i<=num1;i++){
               scanf("%lf",&a[i]); //第i个电缆的长度
               sum+=a[i];
    }
    sum=sum/de; //这里是理想中的平均值,是最大的值。
    L=0;
    R=sum;  //在此题中,所求最大值位于所有电缆之和除于要分的份数和0之间
    while(fabs(L-R)>minn){  //这里的L与R的大小判断要灵活变通,fabs与abs的区别要注意
               int sum1=0;  //电缆的段数
               mid=(L+R)/2;   //二分,缩短搜索的范围;
               for(int i=1;i<=num1;i++){    //搜索每根电缆长度除以mid,判断能分成几根电缆
                  sum1+=(int)(a[i]/mid);
               }
               if(sum1>=de){   //如果分的电缆数小于预定数,则mid大了,应该选择左部
                   L=mid;
               }
               else{
                   R=mid;
               }
    }
    R=(int)(R*100)/100.0;   //提高精度
    printf("%.2f\n",R);
    return 0;
}
发布了36 篇原创文章 · 获赞 1 · 访问量 1401

猜你喜欢

转载自blog.csdn.net/atnanajiang/article/details/103997113
今日推荐