hdu1969 Pie 二分

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16105    Accepted Submission(s): 5669


 

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

 

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

 

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

思路:

易知每个人分得的蛋糕最小为0,最大为最大的那个蛋糕,于是二分,对于每次的蛋糕大小,我们求出蛋糕能够分得的人数x,如果x >m则说明蛋糕分得小了,如果x<m说明蛋糕分得大了;

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<map>
#include<set>
#include<cmath>
#define ll long long
#define pi acos(-1)
using namespace std;
double a[10005],x;
int n;
int solve(double y)
{
    int ans = 0;
    for (int i = 0;i < n;i ++)
        ans += (int)(a[i] / y);
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t --)
    {
        int m;
        scanf("%d %d",&n,&m);
        m ++;
        for (int i = 0;i < n;i ++)
        {
            scanf("%lf",&x);
            a[i] = x * x;
        }
        sort(a,a + n);
        double l = 0,r = a[n - 1],mid;
        while ((r - l) >= 1e-6)
        {
            mid = (l + r) / 2.0;
            int ans = solve(mid);
            if (ans >= m)
                l = mid;
            else
                r = mid;
        }
        double v = pi * mid;
        printf("%.4lf\n",v);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81265497