POJ--2549--折半枚举

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input
5
2 3 5 7 12
5
2 16 64 256 1024
0
Sample Output
12
no solution

思路:折半枚举即可;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int MAX=1000+10;
const int inf=-600000000;
long long int n,a[MAX];
int main(){
	while(scanf("%lld",&n)!=EOF&&n){
		for(int i=0;i<n;i++)
			scanf("%lld",&a[i]);
		sort(a,a+n);//应该可以不用考虑
		n--;
		long long int ans=inf;
		for(int i=n;i>=0;i--){ 
			for(int j=n;j>=0;j--){
				if(i==j)	continue;
				long long int sum=a[i]-a[j];
				for(int c=0,d=j-1;c<d;){
					if(a[c]+a[d]==sum){ 
						ans=a[i];
						break;
					}else if(a[c]+a[d]>sum){ 
						d--;
					}else
						c++;
				}
				if(ans!=inf)	break; 
			}
			if(ans!=inf)	break;
		} 
		if(ans==inf)	printf("no solution\n");
		else	printf("%d\n",ans);
	}
}
发布了150 篇原创文章 · 获赞 73 · 访问量 6590

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104223218