POJ-4 Values whose Sum is 0(2875)——折半枚举+二分查找

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/u011956367/article/details/97502250

4 Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目大意:

给出4个数列,从每个数列中选取一个元素,有多少种组合使得和为0?

思路:

首先将4个数列合并为两个数列的部分和,然后比较合并后的两个数列是否有和为0的情况。

将合并后的第二个数组进行排序,用二分查找找到相反数的下限,然后统计下限到上限的距离。

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
int num[4][4000];//原数组 
int nu1[4000*4000];//合并数组1 
int nu2[4000*4000];//合并数组2 
int main(){
	int n;
	cin>>n;//原数组长度 
	int m=n*n;//合并数组长度 
	for(int i=0;i<n;i++){
		for(int j=0;j<4;j++){
			cin>>num[j][i];//输入 
		}
	}
	int p=0;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			nu1[p]=num[0][i]+num[1][j];//数组1合并 
			nu2[p++]=num[2][i]+num[3][j];//数组2合并 
		}
	}
	sort(nu2,nu2+m);//排序 
	int time=0;//条件符合计量 
	for(int i=0;i<m;i++){//二分查找下限 
		int l=0,r=m,mid;
		int _t=0;
		while(r>l){
			mid=(l+r)/2;
			if(nu1[i]+nu2[mid]<0) l=mid+1;//如果小于0,则下限+1 
			else r=mid; 
			while(nu1[i]+nu2[l]==0&&l<m){
				time++;//条件符合计次 
				l++;//下限右移 
			}
		}
	}
	cout<<time;//输出 
}
扫描二维码关注公众号,回复: 7660764 查看本文章

猜你喜欢

转载自blog.csdn.net/u011956367/article/details/97502250