[折半枚举] 4 Values whose Sum is 0 POJ 2785

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 27860   Accepted: 8383
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source



#include <iostream>
#include <algorithm>
using namespace std;
const int mn = 4010;
int a[4][mn];
int b[mn * mn];
int c[mn * mn];
int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
		for (int j = 0; j < 4; j++)
		cin >> a[j][i];
	
	// 枚举上两行和下两行各自的可能性 再二分查找
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < n; j++)
			b[i * n + j] = a[0][i] + a[1][j];
	}
	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < n; j++)
			c[i * n + j] = a[2][i] + a[3][j];
	}
	
	long long res = 0;
	sort(c, c + n * n);
	
	for (int i = 0; i < n * n; i++)
	{
		int u = -b[i];
		res +=  upper_bound(c, c + n * n, u) - lower_bound(c, c + n * n, u);
		// (>的标号) - (≥ 的标号) = =的个数
	}
	cout << res << endl;
	
	return 0;
}


猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80983968