POJ 2758 4 Values whose Sum is 0(折半枚举)

POJ - 2785 

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题目求a+b+c+d=0的组合数,等价于a+b=-(c+d)的组合数

upper_bound(begin,end,num)-----→找到大于num的第一个数,返回地址

lower_bound(begin,end,num)-----→找到大于等于(重点!)num的第一个数,返回地址

upper_bound(begin,end,num)-lower_bound(begin,end,num)-----→若为1,存在num;若为0,不存在
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
const int maxn=40005;
using namespace std;

int ans=0,n; 
int a[maxn],b[maxn],c[maxn],d[maxn],f[16000005];

int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
	for(int i=1;i<=n;i++)
	    for(int j=1;j<=n;j++)
	        f[(i-1)*n+j]=c[i]+d[j];
	sort(f+1,f+1+n*n);
	for(int i=1;i<=n;i++)
	    for(int j=1;j<=n;j++)
	    {
	    	int F=-a[i]-b[j];
	    	ans+=upper_bound(f+1,f+n*n+1,F)-lower_bound(f+1,f+n*n+1,F);
		}
	printf("%d\n",ans);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/82757339