POJ 2785 4 Values whose Sum is 0(二分 折半枚举)

4 Values whose Sum is 0

Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions:28912   Accepted: 8745
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

折半。先考虑 a+b 在考虑c+d

二分查找第二个中是否有满足和为0的数。

利用了 STL 中的 upper_bound  lower_bound

STL中的函数:(使用前要先排序。)

1.lower_bound算法返回一个非递减序列[first, last)中的第一个大于等于val的位置,
2.upper_bound算法返回一个非递减序列[first, last)中的第一个大于val的位置。

如果所有元素都小于val, 则返回last的位置;

#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <queue>
#include <cmath>
using namespace std;
#define N 4500
#define ll long long
int a[N],b[N],c[N],d[N];
int num[N*N],n;
int main()
{
    cin.tie(0);
    ios::sync_with_stdio(false);
    int cnt=0,ans=0;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>a[i]>>b[i]>>c[i]>>d[i];
    }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            num[cnt++]=a[i]+b[j];
        }
    }
    sort(num,num+cnt);
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            int temp=c[i]+d[j];
            ans+=(upper_bound(num,num+cnt,-temp)-lower_bound(num,num+cnt,-temp));
        }
    }cout<<ans<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81433634