poj 2785(折半枚举 双向搜索)

4 Values whose Sum is 0

Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 32325   Accepted: 9932
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:有4个数列   每列找一个数,得到和为0的序列,有几种不同的方案

对1,2列的数求一个和,3,4列的数求一个和,然后进行二分查找

分析:如果一个一个枚举那么总共有n^4种情况  但是要全部判断一遍是不行的。不过将他们对半分成AB和CD在考虑,就可以快速地解决问题了。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=4005;
int a[N],b[N],c[N],d[N],e[N*N];
int main()
{
	int n;
	while(scanf("%d",&n)==1){
		for(int i=0;i<n;i++){
			scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				e[i*n+j]=c[i]+d[j];
			}
		}
		sort(e,e+n*n);
		int cnt=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				int cd=-(a[i]+b[j]);
				cnt+=upper_bound(e,e+n*n,cd)-lower_bound(e,e+n*n,cd);
			}
		} 
		printf("%d\n",cnt);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/CC_1012/article/details/89055538