POJ--2785--折半枚举

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路:折半枚举,排序查找;时间复杂度(O(n^2*log(n));

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int MAX=4000+10; 
int n,a[MAX],b[MAX],c[MAX],d[MAX];
int ab[MAX*MAX];
/*Time limit15000 msCase time limit5000 msMemory limit228000 kB*/ 
void init(){
	for(int i=0;i<n;i++){ 
		scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
	} 
}
int main(){
	while(scanf("%d",&n)!=EOF&&n){
		init();
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				ab[i*n+j]=a[i]+b[j];//这里用三个for循环数组溢出,不能实现 
		sort(ab,ab+n*n);
		long long ans=0;
		for(int i=0;i<n;i++)	
			for(int j=0;j<n;j++){ 
				int cnt=-(c[i]+d[j]);
				ans+=upper_bound(ab,ab+n*n,cnt)-lower_bound(ab,ab+n*n,cnt);
			} 
		printf("%lld\n",ans);	
	}
	return 0;
} 

假期实在是太太无聊了...

发布了150 篇原创文章 · 获赞 73 · 访问量 6589

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104223257