Matches Game(尼姆博弈)

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.
Input
The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.
Output
For each test case, output “Yes” in a single line, if the player who play first will win, otherwise output “No”.
Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

题意描述:给出一个m在给出m个数,每个数代表一个石子堆里边石子的个数,然后两个人在哪里取石子,每次只能在一堆里边取石子,可以取出若干个,但是不能不去,但也不能取出的个数大于这个堆得总共石子的个数。

AC代码:

#include<stdio.h>

int main()
{
    int n,ans,temp,i;
    while(scanf("%d",&n)!=EOF)
    {
        temp=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&ans);
            temp^=ans;
        }
        if(temp==0)  
			printf("No\n");
        else
			printf("Yes\n");
    }
    return 0;
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1362

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/98359903