Matches Game (尼姆博弈)

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

题目大意:

有M(1<=M<=20)堆火柴, 每堆火柴有多个,两个人轮流取,每次每人只能从一堆中取,每人至少取一个,最多将该堆取完,最后取完火柴的人赢,如果先取的人赢,输出Yes,否则输出No。

尼姆博弈(Nimm Game):有三堆各若干个物品,两个人轮流从某一堆取任意多的物品,规定每次至少取一个,多者不限,最后取光者得胜。(对尼姆博弈,我们有这样地结论:用(a,b,c)表示每堆石子数目,如果a^b^c==0,就称这种局势是奇异局势,那么先手一定输。)

#include <stdio.h>
#include <string.h>	
int s,i,n,a[10000010];
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		s=0;
		memset(a,0,sizeof(a));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			s=s^a[i];
		}
		if(s==0)
			printf("No\n");
		else
			printf("Yes\n");	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81111824