POJ2234 Matches Game【Nim博弈】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11069   Accepted: 6469

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

Source

POJ Monthly,readchild

问题链接POJ2234 Matches Game

问题简述

  有n堆石子,每次可以从任意一堆拿任意数量的石子,至少拿1个,两人轮流进行,问先手是否必胜?

问题分析:(略)

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ2234 Matches Game */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int m, ans, a;
    while(scanf("%d", &m) != EOF) {
        ans = 0;
        while(m--) {
            scanf("%d", &a);
            ans ^= a;
        }
        printf("%s\n", ans == 0 ? "No" : "Yes");
    }

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80174169