POJ 2234 - Matches Game(Nim博弈)

版权声明:欢迎转载 https://blog.csdn.net/l18339702017/article/details/82156926

Matches Game

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11636   Accepted: 6824

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

Source

POJ Monthly,readchild

Nim博弈板子

#pragma GCC optimize(2)
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define rep(i,x,y) for(int i = x; i < y; i++)
#define Rep(i,x,y) for(int i = x; i <= y; i++)
#define per(i,x,y) for(int i = x; i >= y; i--)
#define line cout << "------------" << endl

typedef long long ll;
const int maxn = 1e5 + 10;
const int MAXN = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1010;


int main(){
	int n;
	while(scanf("%d",&n) != EOF){
		int stone , tag = 0;
	while (n--){
        scanf("%d", &stone);
        tag ^= stone;
    }
    printf("%s\n", tag == 0 ? "No" : "Yes");
	}
	
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/82156926