H - Matches Game

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

题意概括  :

有m堆石子,每堆石子个数是n,双方轮流从中取物品,每次取部分或全部,最多将该堆物品取完,最后取完物品的人赢,如果先手赢输出Yes,后手输出No.

解题思路  :

将每堆物品的数量异或起来,如果最后结果为零,则输出No,否则输出Yes。

#include<stdio.h>
#include<math.h>

int m,a,b,temp;
int main()
{
	 int i; 
	 while(~ scanf("%d",&m))
	 {
	 	temp = 0;
	 	for(i = 0;i<m;i ++)
	 	{
	 		scanf("%d",&a);
	 		temp ^= a;
		 }
		 if(temp == 0)
		 printf("No\n");
		 else
		 printf("Yes\n");
	 }
	 return 0;	
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81142879