poj-2234-Matches Game(博弈)

Matches Game

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

题意描述:

从n堆石子中任取一堆或一堆中的部分,谁最后把石子取完谁获胜,求先手能否获胜

程序代码:

#include<stdio.h>
int main()
{
	int a[25];
	int i,n,count;
	while(scanf("%d",&n)!=EOF)
	{
		count=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			count^=a[i];
		}
		if(count==0)
			printf("No\n");
		else
			printf("Yes\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81108593