1041 Be Unique (20 分)(map以及STL的应用)

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

分析

本题考查map以及STL的应用,属于简单题

#include <iostream>
#include <map>
#include <vector>
using namespace std;
int a[10010];
int main(){
	int n;
	cin>>n;
	vector<int> v(n);
	for(int i=0;i<n;i++) {
		cin>>v[i];
		a[v[i]]++;
	}
	for(auto it :v){
		if(a[it]==1){
			cout<<it<<endl;
			return 0;
		}
	}
	cout<<"None"<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/82992704