PTA Palindromic Number (25分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include<climits>//INT_MAX
//#include<bits/stdc++.h>
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
typedef long long ll;
using namespace std;
int const mod=1e9+7;
const int maxn=2e3+10;
string s;
int k,ct;
void add(string t)
{
    int cd=s.length(),jw=0;
    for(int i=0;i<cd;i++)
    {
        s[i]=s[i]+t[i]+jw-'0';
        jw=0;
        if(s[i]>'9')
        {
            s[i]=s[i]-10;
            jw=1;
        }
    }
    if(jw)
        s+='1';
    reverse(s.begin(),s.end());
}
bool pd(string s)
{
    string ls=s;
    reverse(ls.begin(),ls.end());
    if(ls==s)
        return true;
    else
        return false;
}
int main()
{
    cin>>s>>k;
    while(!pd(s)&&ct<k)
    {
        ct++;
        string t=s;
        reverse(t.begin(),t.end());
        add(t);
    }
    if(ct==0)
    {
       cout<<s<<endl;
       cout<<0<<endl;
    }
    else{
       cout<<s<<endl;
       cout<<ct<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/108571572