PAT甲级——Eddington Number (水题)

1117 Eddington Number (25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

 题目大意:一个人骑行了N天,每天的行程距离都有记录;要求找出Eddington Number,也就是有E天,每天的行程都超过E公里,且E为能找到的最大的正整数。

思路:把行程距离存入数组并排好序,从大往小数,当 v[i] <= E 时 E-1就是答案。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
	int N, dis, i, E = 1;
	scanf("%d", &N);
	vector <int> v(N);
	for (int i = 0; i < N; i++)
		scanf("%d", &v[i]);
	sort(v.begin(), v.end());
	for (i = N - 1; i >= 0; i--) {
		if (v[i] <= E) 
			break;
		E++;
	}
	printf("%d", E-1);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44385565/article/details/89855411