【题解】- hdu Switch Game【找规律】

Switch Game

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

Input

Each test case contains only a number n ( 0< n<= 10^5) in a line.

Output

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

Sample Input

1
5

Sample Output

1
0


        
  

Consider the second test case:

The initial condition	   : 0 0 0 0 0 …
After the first operation  : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation  : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation  : 1 0 0 1 0 …

The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

Hint

hint
        
 

AC代码

#include<stdio.h>
#include<string.h>
int main(void)
{
    int n,arr[100001],i;
    memset(arr,0,sizeof(arr));
    for(i = 1; i * i <= 100000; i ++)
    arr[i * i] = 1;
    while(scanf("%d",&n) != EOF)
    {
        if(n<0||n>100000)
        break;
        printf("%d\n",arr[n]);
    }
    return 0;
}

思路

一开始有n盏灯,且全部为关闭状态,都记为 0 就是 The initial condition : 0 0 0 0 0 …

然后之后进行i操作就是对这些灯以是否能被i整除,进行改变状态,如将 0 改为 1 或 将 1 改为 0

正如提醒里的

After the first operation : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation : 1 0 0 1 0 …

扫描二维码关注公众号,回复: 8885183 查看本文章

然后题目的输出是 第i次操作的第i个的状态,正如上面红色标记的

将前十个写出来可以找到规律

  1. 1 1 1 1 1 1 1 1 1 1 1 1 1
  2. 1 0 1 0 1 0 1 0 1 0 1 0 1
  3. 1 0 0 0 1 1 1 0 0 0 1 1 1
  4. 1 0 0 1 1 1 1 1 0 0 1 0 1
  5. 1 0 0 1 0 1 1 1 0 1 1 0 1
  6. 1 0 0 1 0 0 1 1 0 1 1 1 1
  7. 1 0 0 1 0 0 0 1 0 1 1 1 1
  8. 1 0 0 1 0 0 0 0 0 1 1 1 1
  9. 1 0 0 1 0 0 0 0 1 1 1 1 1
  10. 1 0 0 1 0 0 0 0 1 0 1 1 1

除了 n*n 是 1 ,其余的都是 0

发布了34 篇原创文章 · 获赞 2 · 访问量 895

猜你喜欢

转载自blog.csdn.net/Kapo1/article/details/103545928