HDU - 6312 GAME(题解)

Alice and Bob are playing a game.
The game is played on a set of positive integers from 1 to n.
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored.
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses.
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

Input

There might be multiple test cases, no more than 10. You need to read till the end of input.
For each test case, a line containing an integer n. (1≤n≤5001≤n≤500)

Output

A line for each test case, 'Yes' or 'No'.

Sample Input

1

Sample Output

Yes

总结:一开眼,看题。博弈题,但博弈题没怎么做过,所以内心有点惧,一开始找规律,写了几个都是Yes,内心更是恐惧,队友对题目产生疑问,我也没信心在做下去了。所以还是要多刷题,积累类似经验,掌握方法。

分析:因为1是任何数的因数所以2种情况:

1.拿1必胜情况。这时候先手拿一必胜。

2.拿1必败,此时先手拿2此时1也被拿去,转化成先手必胜。

代码就很简单了,如下:

#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
	int n;
	while (scanf("%d", &n)!=EOF)
	{
		cout << "Yes" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/fighting_yifeng/article/details/81267783