hdu 1079 Calendar Game(博弈论 找规律)

 Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.
Output
Print exactly one line for each test case. The line should contain the answer “YES” or “NO” to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of “YES” or “NO”.
Sample Input

3 
2001 11 3 
2001 11 2 
2001 10 3 

Sample Output

YES 
NO 
NO 

题解:
题目:给定一个日期,每次只能选择到下一个月或下一天,问该条件下是否先手能胜

我们可以找一下规律:
2001 11 4 后手
2001 11 3 先手
2001 11 2 后手
2001 11 1 先手



2001 10 4 先手
2011 10 3 后手



因此我们可以发现:
当月份和日期相加为偶数时, 那么先手必胜(当然啦,特例还是有的啦~)
我们会发现正常情况下,无论是月份加一还是日期加一都会使和的奇偶性发生改变,但怎么可能都正常呢~
eg.9.30 和 11.30 日期加一后奇偶性就没发生改变~ 所以这两个特例先手也是会赢的~~ 是不是很有趣~~

os:年份完全没用 , 什么平年,闰年完全没用 ~混淆视线太成功了~ 我果然还是太菜了

#include<bits/stdc++.h>
using namespace std;

int main(){
    int t, a, b, c;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d%d", &a, &b, &c);
        if((b + c) % 2 == 0 || (b == 9 && c == 30) || (b == 11 && c == 30))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/81287150