Switch Game

   There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
InputEach test case contains only a number n ( 0< n<= 10^5) in a line.
OutputOutput the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).Sample Input
1
5
Sample Output
1

0

----------------------------我是滑稽的分割线------------------------------------------------------------------------

思路分析:

每个人进入都会改变灯的状态,第n个进入就会改变n的倍数的号的灯,比如第一个进所有数字都被改变,第二个进,2、4、6、8....状态会反转。

实质上就是求:一个数字的因子个数。

回顾总结:

该题暂未遇到坑。

#include <iostream>
#include<string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int lamp[100001];
//求能被这个数整除的个数 
int main(int argc, char** argv) {
int n;
while(cin>>n)
{
	int ct=0;
	for(int i=1;i<=n;i++)
	{
		if(n%i==0)
		ct++;
	 } 
	 if(ct%2==0)
	 {
	 printf("0\n");
	 }
	 else
	 {
	  printf("1\n");
	 }
}

	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_32835707/article/details/60595358