【递推】Fibonacci Again

描述

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

输入

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

输出

Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

样例输入

0
1
2
3
4
5

样例输出

no
no
yes
no
no
no

题目来源

HDOJ
分析:斐波那契递推。
代码:
#include<bits/stdc++.h>
using namespace std;
int f[1000001];
void Fibo()
{
f[0]=7;f[1]=11;
for (int i=2;i<1000001;i++)
f[i]=(f[i-1]+f[i-2])%3;
}
int main()
{
Fibo();
int n;
while(cin>>n)
{
if (f[n]%3==0)
cout<<“yes”<<endl;
else
cout<<“no”<<endl;
}
return 0;
}

发布了69 篇原创文章 · 获赞 0 · 访问量 1765

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104079423