HDU 1021(Fibonacci Again)

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/86611506
                                               Fibonacci Again
           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                      Total Submission(s): 78550    Accepted Submission(s): 35537

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

#include<iostream>
using namespace std;
int main()
{
    long long int n;
    while(cin>>n)
    {
        if((n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/86611506