G - Fibonacci Again

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

题意:有一个斐波拉且数列,求是否f[n]能整除3

思路1:由于数据过大,会超出任何类型的表达范围,所以我用了同余定理

                (a+b) % c = a %c + b % c,能整除的部分已经被我们去除,我们考虑的是不能整除的那部分,从而值不会超出表示范围

#include<stdio.h>
const int maxn = 1000000+1;
int f[maxn] = {0}; 
int main()
{
	int n,i;
	int flag;	
	f[0] = 7;f[1] = 11; 
	for(i = 2;i <= maxn;++i)  //可用(a+b) mod c = a mod c + b mod c 
	{
	    f[i-1] %= 3;
	    f[i-2] %= 3;
	    f[i] = f[i-1]+f[i-2];
	}
	
	while(scanf("%d",&n)!=EOF)
	{
		flag = 0;		
	    if(f[n]%3 == 0)
			flag = 1;	    
	    if(flag)
	      printf("yes\n");	
	    else
	      printf("no\n");
	
	} 
	return 0;
}

思路:从第二项起,每四项输出结果重复一遍

#include<iostream>
using namespace std;
int main()
{
	int n;
	while (cin>>n)
	{
		if ((n - 2) % 4 != 0)
			cout << ("no") << endl;
		else
			cout << ("yes") << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40511966/article/details/84196593