hud-1058 Humble Numbers(优先队列)

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1 2 3 4 11 12 13 21 22 23 100 1000 5842 0

Sample Output

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

 题意:问因子只含有2,3,5,7的第k个数是什么?

#include<bits/stdc++.h>
#include<cstdio>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<cmath>
#include<vector>
#include<cstring>
#include<string>
#include<iostream>
#include<iomanip>
#define mset(a,b)   memset(a,b,sizeof(a))
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
//const int mod=100000007;
const int N=505050;
//const int inf=0x3f3f3f3f;
//priority_queue<int,vector<int>,greater<int> >q;
ll a[6000];
priority_queue<ll,vector<ll>,greater<ll> >q;
set<ll>s;
int b[4]={2,3,5,7};
int main()
{
    q.push(1);
    for(int i=1;i<=5842;i++)
    {
        ll x=q.top();
        q.pop();
        a[i]=x;
        for(int j=0;j<4;j++)
        {
            ll y=x*b[j];
            if(!s.count(y))
            {
                s.insert(y);
                q.push(y);
            }
        }
    }
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            return 0;
        printf("The %d",n);
        if(n%10==1&&n%100!=11)
            printf("st humble number is %lld.\n",a[n]);
        else if(n%10==2&&n%100!=12)
            printf("nd humble number is %lld.\n",a[n]);
        else if(n%10==3&&n%100!=13)
            printf("rd humble number is %lld.\n",a[n]);
        else
            printf("th humble number is %lld.\n",a[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Kuguotao/article/details/88710604